Back to overview
Degraded
SCA/3DS failures
Sep 25 at 12:32pm BST
Affected services
payment-assist.co.uk
Resolved
Sep 25 at 02:55pm BST
This issue is now resolved.
Affected services
payment-assist.co.uk
Created
Sep 25 at 12:32pm BST
Our payments gateway, Barclaycard, is currently experiencing an outage with card 3DS/SCA verification. This is unfortunately out of our direct control however we will relay updates as they are made available to us.
This issue is preventing checkout completion on new applications.
Affected services
payment-assist.co.uk